Quantcast

What version of Java is NetRexx java source output really at?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

What version of Java is NetRexx java source output really at?

Jason Martin
Not the version required to compile NetRexx itself but the least version
 required for the actual Java source output excluding added API's.

I know the keywords have not changed that much.

What is the least version for the runlib itself?

_______________________________________________
Ibm-netrexx mailing list
[hidden email]
Online Archive : http://ibm-netrexx.215625.n3.nabble.com/

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: What version of Java is NetRexx java source output really at?

Kermit Kiser
I will take a stab at answering this although I can't verify my guesswork right now. This is just what my fuzzy memory recalls.

Mike released NetRexx when Java was at the 1.1 level. Later when Java went to 1.2, Mike enhanced NetRexx to include the interpreter. After that there were no changes except a few minor bug fixes I think. Since mid 2011 when RexxLA took over the development, we have made substantial changes to fix bugs and to improve performance but no changes to the language syntax or output Java code as far as I know.

As a result, the Java code produced by the NetRexx translator is still likely at the Java 1.2 or even 1.1 level. That information seems of little value however since both the translator and the runtime library use collection classes and compiler API features, etc from Java up to 1.6 now so any practical programs would require that Java level even if we don't add new language features as plans call for doing soon.

Kermit


On May 5, 2016 10:04:37 PM PDT, Jason Martin <[hidden email]> wrote:
Not the version required to compile NetRexx itself but the least version
 required for the actual Java source output excluding added API's.

I know the keywords have not changed that much.

What is the least version for the runlib itself?



Ibm-netrexx mailing list
[hidden email]
Online Archive : http://ibm-netrexx.215625.n3.nabble.com/


--
Sent from my Android device with K-9 Mail.
_______________________________________________
Ibm-netrexx mailing list
[hidden email]
Online Archive : http://ibm-netrexx.215625.n3.nabble.com/

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: What version of Java is NetRexx java source output really at?

Jason Martin
In reply to this post by Jason Martin
Thank you greatly Kermit but it is of GREAT value if you doing something with the actual output itself.
I thought what you say must be true but was not sure. Any other input from anybody else is welcomed.

Sometimes things are not as complicated as they seem.


On Fri, May 6, 2016 at 1:04 AM, Jason Martin <[hidden email]> wrote:
Not the version required to compile NetRexx itself but the least version
 required for the actual Java source output excluding added API's.

I know the keywords have not changed that much.

What is the least version for the runlib itself?


_______________________________________________
Ibm-netrexx mailing list
[hidden email]
Online Archive : http://ibm-netrexx.215625.n3.nabble.com/

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: What version of Java is NetRexx java source output really at?

rvjansen
Only testing can confirm but it is mostly 1.1.
If you want the runlib linked you will have to compile the java source with a compiler that produces downlevel bytecode.

Of course, when you are going to include the new annotations you will be at Java 1.5 source level.

Btw, the current trunk has those, but a broken trace. I intend to fix that soon.

Best regards,

René.

On 07 May 2016, at 02:47, Jason Martin <[hidden email]> wrote:

Thank you greatly Kermit but it is of GREAT value if you doing something with the actual output itself.
I thought what you say must be true but was not sure. Any other input from anybody else is welcomed.

Sometimes things are not as complicated as they seem.


On Fri, May 6, 2016 at 1:04 AM, Jason Martin <[hidden email]> wrote:
Not the version required to compile NetRexx itself but the least version
 required for the actual Java source output excluding added API's.

I know the keywords have not changed that much.

What is the least version for the runlib itself?

_______________________________________________
Ibm-netrexx mailing list
[hidden email]
Online Archive : http://ibm-netrexx.215625.n3.nabble.com/


_______________________________________________
Ibm-netrexx mailing list
[hidden email]
Online Archive : http://ibm-netrexx.215625.n3.nabble.com/

Loading...